At his time all issues related to this outage appear to be resolved.
Posted Dec 08, 2025 - 14:51 EST
Update
There are between 500 to 2000 customers affected, the cause is "Network Damage" which we would understand to be physical damage to some lines or equipment. We are seeing more customers coming online but those that do are often having speed issues.
We will pass on any more info as we receive it.
Posted Dec 08, 2025 - 12:43 EST
Identified
We have a number of Comcast customers down, we are reaching out to Comcast support to see if there is any ETA.
Posted Dec 08, 2025 - 11:48 EST
This incident affected: Comcast Internet Services.