VOIP Phone system quality issues
Incident Report for Unified Technology Solutions
Resolved
This incident has been resolved.
Posted Apr 18, 2024 - 14:04 EDT
Identified
Working with Flowroute it has been identified by their inbound peers that AT&T is currently experiencing outages within the Florida region. AT&T has not yet provided timelines for resolution, but we'll let you know as we receive further updates from those peering networks.
Posted Apr 17, 2024 - 15:57 EDT
Investigating
We have multiple reports of phone service quality issues we believe we have traced to Flowroute which is the VOIP service provider. We have opened multiple tickets with them. We will update you when we have more info.
Posted Apr 17, 2024 - 12:27 EDT
This incident affected: UTS Operator - Hosted Phone Systems.