Hurricane Milton
Incident Report for Unified Technology Solutions
Update
Comcast service is restored for the most part but is suffering from periodic drops. FPL has restored power except to those directly hit by the tornados.
Posted Oct 17, 2024 - 13:22 EDT
Update
As many of you are aware Comcast Internet has been going up and down the past few days, this is happening all over the service area Including our own office. All we can do is be patient and understand you are not the only on affected.
Posted Oct 15, 2024 - 14:46 EDT
Identified
Sorry for the late update but our time has been taking assessment of our clients status and it has come to our attention that a large number of Comcast Customers are offline, so many that we are unable to confirm any customer in the County whose Comcast connection is currently working. What this means is you will likily not have Internet service at your office and we ask you to plan accordingly. It is possible Comcast will not even allow us to open individual tickets until the bulk of the area is online.

We wanted to get this info to you as quickly as possible so you can plan accordingly.
Posted Oct 10, 2024 - 20:39 EDT
Update
We have confirmed our office has internet and power and we will return to normal operations tomorrow. Our priority will be customers with major issues/outages so we appreciate your patience as we help all our customers get back to normal as quickly as possible.

Right now, per FPL about 27% of the county is without power. Comcast and AT%&T do not publicly release outage info so it is hard to say how many are affected, fiber customers are usually ok but we expect a number of Comcast Coax customers to be down from past experience. If you know your power or Internet is down please let us know through the ticket system, we will try to open tickets with Comcast as quickly as possible but we expect them to be very busy with long hold times so if you have the ability to report it yourself through their website it will help the process.

We hope you and your employees all faired well through the storm and we promise we will work to get your business technology back up as quickly as possible.

We will keep this incident open until some time tomorrow in case we need to spread any other info about outages.
Posted Oct 10, 2024 - 16:49 EDT
Update
We are seeing multiple FP&L and Comcast Internet outages in the area. At this time we are suspending helpdesk services so that our employees can focus on protecting their families.
Posted Oct 09, 2024 - 16:06 EDT
Update
As the storm approaches we remind clients to stay in contact through our ticket system letting us know when you plan to reopen so we can be ready to provide assistance if needed.

Please remind your employees if they send in support requests to include a phone# for us to contact them if they are working remotely. Also remember if you are planning for employees to work remotely after the storm someone from your staff will likely need to go to your office and power on to all the PCs if power was lost during the storm.

Due to anticipated conditions tomorrow we do not expect to we will have the ability to provide regular support services. We will take care of any requests as soon as we are able to do so.
Posted Oct 09, 2024 - 12:36 EDT
Update
Due to the forecast for Hurricane Milton, we will be closing our office on Wednesday. However, our team will continue working remotely, as conditions allow, and support will be available via email or return calls. Please note, if you call, you may need to leave a voicemail, and we will return your call as soon as possible.

If you expect to need any assistance or changes before the storm hits, especially changes to phone systems, we ask you to notify us, even with partial info, so we can be ready.
Posted Oct 07, 2024 - 15:44 EDT
Monitoring
We are monitoring the forecast track.
Posted Oct 07, 2024 - 11:49 EDT
Investigating
We are monitoring the situation with Hurricane Milton and its impact to our area. We will be using this single Incident to track services that could possibly be affected by the storm. The good news is that the northern shift of the latest forecast will lessen the impact locally. If you feel you may require any assistance preparing for the storm please let us know.

If you plan to update your phone system recordings, please inform us now through a support ticket, even if you're unsure of the exact timing, so we can prepare as much as possible.
Posted Oct 07, 2024 - 11:47 EDT
This incident affects: Comcast Internet Services and FP&L Electric Service.